Windows general breakdown

I’m currently having an issue with my Csound install on Windows 10. I don’t use it often on Windows, but I’m pretty sure it was working last time.

  • I get no sound out
  • csound --devices returns the following :
0 audio input devices
0 audio output devices

And when starting a realtime performance, Csound also returns
unknown rtaudio module: 'PortAudio', using dummy module
(same if I change for winmme or anything else)

In the same time, my audio device is detected correctly by windows, working with Reaper, detected by web browser and everything.

I wanted to download a new version (I had 6.14 or something) and found out that the two first links (installer and binaries for 64bits) are dead on Installing the XP 64 bits didn’t solve the problem

So I tried to build it myself (with MSVC), and ended with this issue :

 Could not find a package configuration file provided by "SndFile" with any
  of the following names:


  Add the installation prefix of "SndFile" to CMAKE_PREFIX_PATH or set
  "SndFile_DIR" to a directory containing one of the above files.  If
  "SndFile" provides a separate development package or SDK, be sure it has
  been installed.
Call Stack (most recent call first):
  CMakeLists.txt:431 (find_package)

I know, that’s a lot of problems. Let’s start with the first one : what might cause Csound not to detect the audio device ? Is that related to portaudio ? Usually, I would have installed a new version to check if it can be solved like this, but unfortunately, I was not able to find binaries / or build some.

Did you try the very latest release for Windows?

The links were broken yesterday on the website.
It’s working perfectly fine now. I guess I overreacted :joy:

I didn’t notice the links were down as I usually just go to github. Nice to know it’s working fine again :slight_smile: