Using Cmake to build Csound Plugins

I am trying to install the csound plugins on my chromebook which is running in developer mode. I have been using CsoundQt with some success other than the fact it keeps crashing often. I am trying to use the python opcodes to create my own GUI’s using PythonQt. So I followed the directions to build the plugins on Linux and MacOs, I am given the following error:
“CMake Error at CMakeLists.txt:44 (message):
Csound header files are required”
Is there anything I can do to get this build to work? Do I need to amend the CMakeLists.txt file to get cmake to work with no errors?


You need to have Csound header files. Either you should install Csound-dev package or better to build Csound yourself and install.

Might be that they are in some different place on Chromebook.

To build PythonQt you need also all possible Qt development pacakages.


N, 19. oktoober 2023 01:59 Joshua via The Csound Community <> kirjutas:

Hey Johannes, thanks for replying to my question. I ended up uninstalling the version of csound I got from apt and building csound from source which built fine and is working good. So I went back and tried to build the plugins and ran cmake …/ and it worked. I typed make and enter and the terminal tells me make needs a target. Is the correct target CMakeCache.txt in the build directory or CMakeLists.txt in the plugins directory? Or is it something else entirely? And also another closely related question: under Install Location it says Linux depends on CMAKE_INSTALL_PREFIX and USE_LIB64 what exactly are those? I am sorry I am new to programming and linux. I have a lot of questions.

Screenshot 2023-10-21 07.45.42

The python opcodes are no longer part of the official Csound repo. They are available here:

Is this the repo what you are trying to build from?

Hey Rory, Yes!

So after following the instructions at “GitHub - csound-plugins/csound-plugins: Plugins for csound” using risset I was able to install those particular plugins. I actually tried first to build instructions but it did not work for me. I think because I followed the build instructions at “Installation - Csound Plugins” which tells you to cmake twice at the end of the steps but --build and --install are in a lighter color so I typed cmake and with nothing following cmake as I thought those word were comments, not that I was supposed to type them in as well. But maybe it would not have worked either way.

1 Like