Problems with MIDI-Input

Hello Everybody!
I don’t get input from my MIDI Device into Csound (tested it with Reaper, there is no problem).
I consulted the floss manual and also tried to print with midiin and print2k. No input form my keaboard.
i don’t get it. Can somebody help?

I used the terminal to execute my .csd.
Is there a way to print my MIDI Input in the Terminal, outside of Csound?
Greetings, Philipp

-odac -W -3 -+rtmidi=coremidi -Ma

sr = 96000
ksmps = 128
nchnls = 2
0dbfs = 1.0

massign 0, 1
instr 1

iCps cpsmidi
iAmp ampmidi 1
aOut poscil3 iCps, iAmp
outs aOut, aOut


II noticed also this two error messages:
could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/libpmidi.dylib’ (-1)
‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/librtjack.dylib’ (-1)

Oh, i soved this. But i still have questions:

I solved it by testing numbers for the flag -M(x) .
Normally -Ma should work with all devices. But for me not. Why is it so?
Also, the way it is described in the floss manual, to get the list of midi devices doesnt work for me. I used -M999 to get all the devices but it just tells me, that im producing an error.

Hi Philipp -

are you using CsoundQt? Or commandline only?

best -

Normally i use the Commandline. But i tried it on both, QT and Terminal.

QT has noch Problems with finding the MIDI Interface and i can choose it from the menu and it works.