Issues with building Java examples in Csound API repo

I’m getting a build error when using the Ant method (also Netbeans) to build the examples on macOS Monterey (M1 silicon)

[javac] /Users/boonier/GIT/csoundAPI_examples/java/src/csoundapiexamples/ error: package csnd6 does not exist
[javac] import csnd6.Csound;

Is the build config not finding the required Csound6 libs? The build.xml references the netbeans build config:

<import file="nbproject/build-impl.xml"/> in which I assume the class path is:

javac.classpath=\ ${libs.csnd6.classpath}

I tried opening the project in Netbeans, and the linter gave the same error about csnd6, so I attempted to relink the package to the project, on running i get:

_jcsound6 native code library failed to load.
java.lang.UnsatisfiedLinkError: no _jcsound6 in java.library.path: /Users/boonier/Library/Java/Extensions:/Library/Java/Extensions:/Network/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java:.
/Users/boonier/GIT/csoundAPI_examples/java/nbproject/build-impl.xml:1341: The following error occurred while executing this line:
/Users/boonier/GIT/csoundAPI_examples/java/nbproject/build-impl.xml:936: Java returned: 1

I’ve got the usual symlinks in /Library/Java/Extensions for csnd6.jar and lib_jcsound6.jnilib

Any ideas? Is this something to do with Rosetta2 maybe?

many thanks