Issue in reading a table with a control


I am wondering why a tool always worked in other orchestras in this case doesn’t work at all.

I am referring to the following lines, starting from line 28:

k_VCO1_off invalue “VCO1_off” ; offset freq

gk_VCO1_off tablei k_VCO1_off, giExp20000, 1

outvalue “VCO1_off_display”, gk_VCO1_off

In the header I have created the table:
giExp20000 ftgen 0, 0, 129, -25, 0, 1.0, 128, 20000.0

It happens that the k_VCO1_off control doesn’t read the table giExp20000, so in the output I get the default values of the control, in the range of 0 and 1.
It always worked in other orchestras, and I really can’t understand what’s the issue here.

Thanks for your support.


foscili_lfo_01_graph.csd (101.0 KB)

i think the problem is that you mix up two ways of creating tables:
in the orc header, you create two tables with ftgen and let csound
assign a number to them.
in the score, you create a lot of tables in assigning numbers directly
to them.

the console output says:
“ftable 100:
WARNING: replacing previous ftable 101
ftable 101:
WARNING: replacing previous ftable 102”

this means:

  • your giExp1_2 table gets the number 101 from Csound but is then
    overwritten in the score,
  • your giExp20000 gets number 102 and is overwritten, too.

you can assign own table numbers to ftgen, for instance:
giExp1_2 ftgen 1000, 0, 129, -25, 0, 1.0, 128, 2.0 ;TABLES FOR EXP SLIDER
giExp20000 ftgen 1001, 0, 129, -25, 0, 1.0, 128, 20000.0 ;TABLES FOR

this works, but i would recommend not to mix the two ways at all, but to
put all tables in the orc header ans let csound assign the numbers.

best -

Thank you Joachim, now everything is clear, I had not thought of this detail. I’ll set the tables in the header.