CsoundQt dac output select failure

This is a problem I’ve encountered before. Haven’t used Csound for a couple of years, so today I downloaded it and did a fresh install.

Totally standard Windows 10 PC, Focusrite USB ASIO audio interface, works fine with everything. Installed Csound and CsoundQt. Went to the CsoundQt Configure box and directed the audio I/O (adc and dac) to the Focusrite USB ASIO device. Clicked the Test Audio button. Here’s the output:

PortAudio: selected output device ‘Focusrite USB ASIO’
*** PortAudio: error: -9985: Device unavailable

I’m working on an article that I’ll be submitting to a website. I’ll be recommending Csound as a cool software option! So how do I get this working, and how can I explain it to readers so they won’t encounter the same problem?


It is hard to tell, I have little personal experience on Windows. Please try and report the following:

  • does CsoundQt work with the internal sound card

  • is the result same (I guess it is) if you run the csd with Run in Terminal? Does command line csound give the same result?

  • can you try both portaudio options (blocking and callback)

  • is there perhaps several Focusrite USB entries in the device list? Like one with directaion, one through something else?

  • is there something that is using the interface in the same time?

  • do you have perhaps another USB interface to try out with?

I will make an experiments on Windows with an USB card when I get a chance.


Kontakt JimAikin via The Csound Community (<noreply@forum.csound.com>) kirjutas kuupäeval P, 14. jaanuar 2024 kell 22:05:

No. However, I get a different result, namely error -9998, invalid number of channels. I’m not sure why the AudioMidiTest.csd is set up with nchnls = 8, but when I switch that back to 2, I get the -9985 error with the internal sound card.

I would need instructions on how to do that.

I tried that. It didn’t change anything.

There are Windows MME and Wasapi items that use the Focusrite, but no other Focusrite ASIO.

Other Windows devices (such as my browser) are able to use it at the same time as another audio program (such as Reason or FL Studio). This should not be a problem.

No. Sorry.

By the way, there’s a trivial bug you may want to know about. When CsoundQt is first launched, if I go directly to the Configure window the popup menu of adc and dac devices opens and closes instantly. it’s not accessible. However, after I hit the Run button once in the main window, the popup list populates normally.

The thing is, NO other audio program EVER has trouble finding the ASIO driver and using it. Why should Csound be any different? I"m not sure this is a CsoundQt problem – but the listserv for Csound failed to send me an email to confirm my registration, so I’m unable to ask the question there.

i am not a windows user either, but i always recommend to set up an
audio card in the system as default, and then select this default in
csoundqt’s configure tab (-adc for input and -odac for output).

but to be honest: if you want to propagate csound for windows users, why
not point to cabbage? i think rory did and does a great job, and for
csoundqt we never had enough support from windows users nor from windows

I’ll try that. I’ve never used Cabbage, but I’ve used CsoundQt off and on (not often) over the years, so I’m more familiar with the UI. Also, there is this caveat is at the top of the Cabbage manual: “It is possible to use Cabbage to run Csound in the more traditional score-driven way, but your success may vary.” Since I like using the score, this is a bit of a concern for me.

I have now confirmed that Cabbage is able to send audio to the Focusrite without trouble. Possibly this is because Cabbage never uses Portaudio at all. You would know more about that than I would.


I updated now CsoundQt-1.1.1-Wind64.zip with Examples and uploaded to Github. Would you download that and see if Examples are present and appear in the menu?

If yes, could you try to open the simplest example, Examples → CsoundQt → Getting Started → Hello World and see if that works.

Probably not. I think it has something to do with the portaudio module. You are right, this is core Csound specific.
You can also try to set input device to none to see if that makes any difference.

To try command line Csound, you should command line (cmd.exe) and type

csound --version

If it finds csound and you see some output, you can try again to run a csd from command line. Type again

leave a space and drag a csd file there from the file manager like
csound C:/Users/Jim/Documents/csound/test.csd


and see if you get any new results


Kontakt JimAikin via The Csound Community (<noreply@forum.csound.com>) kirjutas kuupäeval E, 15. jaanuar 2024 kell 00:09:

I oppose a bit to that - many people DO use CsoundQt on Windows and it does work. I guess, it is a problem of some specific configuration conflict that Jim has.

Cabbage is definitely a great piece of software, I agree here absolutely.


Kontakt joachim heintz via The Csound Community (<noreply@forum.csound.com>) kirjutas kuupäeval E, 15. jaanuar 2024 kell 00:25:

Yes. I downloaded and installed it. The examples are there.

Not only that, but portaudio is now working! I have no idea what changed, if anything. I loaded “Trapped in Convert” and it played. I then loaded and played one of my own .csd files, and it played nicely too.

I’m now using Portaudio(callback) with both the Override and Ignore CsOptions checkboxes checked. However, the in and out fields just say adc and dac. There is no number next to them – and the popup menu boxes with which I might select a specific input or output device never appear. A little dialog box appears and then disappears instantly.

I honestly have no clue what’s going on. It’s working at the moment, so I’m not going to touch anything.

Sorry I’m late to the party. I’m glad you found a solution Jim. FWIW, I’ve found ASIO4ALL to be pretty reliable with Csound. It provides generic ASIO drivers that can interface with most sound cards, and always seems to be picked up without issue by Csound.

And yes, I think CsoundQT is probably a better option than Cabbage if you’re exploring more score driven work.

p.s. nice to see you thinkering with Csound again :wink:

I’ve pitched a website that I sometimes write for on the idea of an article on Csound, so I could see I’d better figure out what’s going on. Lately I’ve been using VCV Rack for computer music experiments – but while VCV is easier to get on with, there’s really no timeline. I’m old-fashioned enough that I like composing in a timeline.