[Csnd] Not sure why...

I’ve got an opcode that I am working on, and I am getting an error “Unable to find opcode entry…”

iTwoBoxes[][] = sw_split(iBBox, “v”, .5)

but when I take it out of the functional form, it works

iTwoBoxes[][] sw_split iBBox, “v”, .5

The opcode definition is

opcode sw_split, i[][], i[]Sj

Do you need more information to give an answer?

Mike

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

I think you may need to specify the type? i.e,

iTwoBoxes[][] = sw_split:k(iBBox, "v", .5)

That has always been an inconsistent fix for things for me. I tried doing

iTwoBoxes[][] = sw_split:i(iBBox, “v”, .25)

and I still get the same error.

I think the function unpacking is not defined for array types, so the functional form doesn’t work.
Steven might know more.

There are some cases where functional form is still undefined in the current parser, but this has been worked through
in the new one that Steven has devised. We need to integrate it, but I think that might only happen in version 7.