[Csnd] Building Csound on Linux: Error message on Portaudio while checking for the dependencies

Dear list,

before building Csound 6.17 on Linux Ubuntu 20.04.3 from the sources today I did experience an error message while checking for the dependencies like this:

janjacobhofmann@janjacobhofmann-ThinkPad-T430:~$ sudo apt-get build-dep csound

It said, that some packages could not be installed. Further it said that some packages (portaudio19-dev and libstk0-dev) are not permitted to be installed.
The full text of the message is below, unfortunately it is just in german.

On the other hand I do experience, that indeed my portaudio driver is not working for me any more, neither on blue (no realtime sound, it gets substituted by a dummy) nor on CsoundQt (portaudio is not available as a driver in the preferences).

Could it be that installing the dev-branch of Csound ist too advanced for my current system? Or do I somehow have to re-install the latest Portaudio-driver or set some permissions differently? Or something else?
I am a bit lost at this point…

Any help appreciated,

Jan Jacob

janjacobhofmann@janjacobhofmann-ThinkPad-T430:~$ sudo apt-get build-dep csound
[sudo] Passwort für janjacobhofmann:
Paketlisten werden gelesen… Fertig
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
builddeps:csound : Hängt ab von: portaudio19-dev soll aber nicht installiert werden
Hängt ab von: libstk0-dev soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

dear jan jacob -

you can try
  sudo apt-get install portaudio19-dev
and see if this solves the problem.

in general, i'd recommenc to use jack, which in turn uses alsa.

best -
  joachim

Dear Joachim,

thanks a lot! Indeed the apt-get install command solved It. I noticed that along with that command jack 2 was uninstalled and instead jack 1 was installed. But I guess that is fine now, as long as everything is working - what do you think?
Now I am getting acquainted with jack, I might come around with some more questions about that sooner or later but for now it is fine!

Thanks again,

Jan Jacob

sound | movement | object | space
sonic architecture | site: http://www.sonicarchitecture.de
spatial electronic composition | higher order ambisonic music

glad it helped! for me, jack1 or jack2 does not make a difference. but if you desperately need jack2, it should work just installing it again.

let's make a jack-for-csound page anywhere in the csound github wiki, starting perhaps with your questions.

best -
  joachim