Cabbage 2.6 is out!

I’m happy to announce Cabbage 2.6 is now available for download. Highlights of this release include much better support for AU and VST3, better multichannel support and out of the box side-chaining, a set of new Cabbage specific opcodes to streamline communication between widgets and Csound, a new presets system, support for FMOD effects, updated VCV Rack interface, new optionsbutton widget and lots of new identifiers to help create killer UIs! Enjoy. Available here



T, 18. mai 2021 12:10 Rory Walsh via The Csound Community <> kirjutas:

Quite a few examples, nice!

So all that UI is done with JUCE eh?

It is, but you can use your own images too. The sliders example uses a PNG image for the slider thumb. So you can make your instruments look however you like.

1 Like

Great! WiIl try it out soon.

Congrats Rory! I tried this here on an M1 Mac and it looks like the build is x86_64 only, is that right? Running from commandline Cabbage complained it couldn’t link with my self-compiled arm64 csound due to wrong architecture. Any chance of getting a universal build?

I’ll look into that Steven. If you’re happy to test it. I don’t have access to an M1 Mac. My own Mac is still running high Sierra, and I’m afraid to update it…

Hi @stevenyi, I add arm64 to build settings for Cabbage, but I doubt it’s as simple as that. Anyhow, maybe you can try the latest build in Azure. You can grab it here

Ah, doesn’t seem to work. The build had the same error when trying to run from commandline and when I run file Cabbbage in the /Applications/ folder, I get:

Cabbage: Mach-O 64-bit executable x86_64

So much for that then. I’ll need time to look into this. For now I might add a note that M1 macs are currently unsupported. :frowning:

Well if you’re on M1 and using x86_64 Csound I imagine it’d work via
Rosetta2, but since I’m self-compiling it’s come up. I don’t know if
DAWs loading x86_64 plugins work. I was looking at a universal binary
build of Csound but the pain is having all dependencies be universal
binaries too.

I think I will have to wait till I have access to an M1 machine. Like you said, I think it might work via Rosetta, but I hear there is a bit of a performance hit there too.