Activate X11 for display opcodes?

Running Csound from a terminal, I’ve found that display will print ASCII-art versions of waveforms (and dispfft has a go at Fourier transforms). It’s cute, but not terribly useful.

The manual page says “Uses X11 windows if enabled…” Since I’m on Linux, I’d have expected X11 to be on by default. How do I turn it on? I can’t see anything relevant in the command-line options.

OK, I’ve found a workaround: the -G command line flag will save .eps format files with actually readable pictures of waveforms, and then I can open them with evince. But I’d still like to hear from anyone else who’s got X11 working.