Re: [Csnd] Questions about Jack

Hi Jan Jacob,
do you have Cadence installed?
I’m running Linux Mint and Manjaro, and the first thing i run is Cadence; it is there where i activate Jack2

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Me too. Cadence is the first tool I install on any new Linux machine.

Hi, Jan,

Can it be that the reason of your problems is that Csound is built without jack support? I guess you built recently Csound yourself and if jack was not installed yet then jack support was not enabled. Can you check if libjack.so is in the plugins folder? Or can you rund some csd with
csound -odac -+rtaudio=jack file.csd

Can you try to install jack development packages (libjackd-dev or something similar, not sure how it is on your system), run cmake again in Csound source directory and check the messages if jack support got enabled. Then build Csound again and for any case do
$sudo ldconfig
to get all the new shared libraries known to the system.

Otherwise it is very strange that CsoundQt does not offer jack as an audio module.

Another thing to know - usually on Linux systems the default audio system nowadays is pulseaudio. Pulse cannot run in parallel with jack (well, there is a bridge that actually allows to run pulseaudio through jack). So, when you start jack and then run CsoundQt or some other program that plays through pulseaudio (and that is the case by Csound wiht its default portaudio module), pulse just waits until it gets access to sound card that is blocked by jack at that moment.

I always use jack for audio work and I love it, never had any problems when you get to know it. I use qjackctl as the front end (just used to it) but cadence is very handy tool, too.

Best greetings,
tarmo

Kontakt Rory Walsh (<rorywalsh@ear.ie>) kirjutas kuupäeval R, 4. veebruar 2022 kell 16:19:

Me too. Cadence is the first tool I install on any new Linux machine.

Hi Jan Jacob,
do you have Cadence installed?
I’m running Linux Mint and Manjaro, and the first thing i run is Cadence; it is there where i activate Jack2

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

this is just a test- please ignore
(perhaps i am just finding out that for me the easiest way to reply is by doing this in the forum…we shall see…)

Jack & pulseaudio-module-jack is my preferred stack,

  • Matt

Sorry for my ignorance(:-/) but I don't know Cadence, and I'm having
trouble locating/identifying it. An aptitude search doesn't show anything
and I'm not sure how to narrow down the mass of hits I get on Google
if I search on the term! Can you give me a pointer?

  -- Pete --

Csound mailing list
Csound@listserv.heanet.ie
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Dear Tarmo;

I guess we are getting closer to the solution: libjack.so is in fact missing in my plugins-folder. I will recompile everything (Csound and CsoundQt) today and then get back to the list for a report.

Thanks to all of you,

Jan Jacob

sound | movement | object | space
sonic architecture | site: http://www.sonicarchitecture.de
spatial electronic composition | higher order ambisonic music

yes this must be the reason. but no need to recompile csoundqt; only csound.

Dear Joachim,

I guess I will have to recompile CsoundQt sooner or later anyway as I am trying to have the latest version of it for a while but I get always seven error messages when I simply try to pull and build the latest version from git.

They are like this:
/home/janjacobhofmann/CsoundQt/src/documentpage.cpp:114: Error: 'std::chrono' has not been declared
114 | auto t0 = std::chrono::high_resolution_clock::now();
> ^~~~~~

so, maybe it's time for a fresh clone anyway. Not to get jack running, but to be able to build the latest version....and maybe the errors while building CsoundQt do vanish with a fresh clone...

Cheers,

Jan Jacob

sound | movement | object | space
sonic architecture | site: http://www.sonicarchitecture.de
spatial electronic composition | higher order ambisonic music

https://kx.studio/Applications:Cadence

Hello again :slight_smile:

I tried a complete rebuild of Csound, but it gives me an error at 86% of compiling after having entered the command:

janjacobhofmann@janjacobhofmann-ThinkPad-T430:~/csound/cs6make$ make -j6

This is what I had done before:
- I removed the existing folders "csound" and "cs6make".

Then I followed the exactly steps from here:

And his is the message I got at the end:

[ 86%] Linking CXX shared library libcsound64.so
[ 86%] Built target csound64
make: *** [Makefile:163: all] Error 2
janjacobhofmann@janjacobhofmann-ThinkPad-T430:~/csound/cs6make$

The processing of the make -j6 command stopped here.

Maybe someone can give me a hint what to do? I am on Ubuntu 20.04.3

Cheers,

Jan Jacob

sound | movement | object | space
sonic architecture | site: http://www.sonicarchitecture.de
spatial electronic composition | higher order ambisonic music

Csound mailing list
Csound@listserv.heanet.ie
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

can you run make again, but without -j6, to see whether you get more output about what the error is?

if this does not say more, run make -d.

run it without -j 6 so we can see where it stopped

Hello Joachim,

thanks! running make reported the following after some processing:

make[2]: *** Keine Regel vorhanden, um das Ziel „/home/janjacobhofmann/csound/csound/po/spanish.po“,
benötigt von „po/es.mo“, zu erstellen. Schluss.
make[1]: *** [CMakeFiles/Makefile2:2407: po/CMakeFiles/pofile_es.dir/all] Fehler 2
make: *** [Makefile:163: all] Fehler 2

To me it looks like something is missing...but I do not know what to do...
Cheers,

Jan Jacob

sound | movement | object | space
sonic architecture | site: http://www.sonicarchitecture.de
spatial electronic composition | higher order ambisonic music

hi ---

in your cs6make folder should be a file called CMakeCache.txt. around line 700 you probably find this:

//Use the Gettext internationalization library
USE_GETTEXT:BOOL=ON

can you try to set OFF instead of ON? then save and run cmake again.

best -
  j

Or install spo/spanish.po

Csound mailing list
Csound@listserv.heanet.ie
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

(Attachment spanish.po is missing)

Dear Joachim, dear Victor,

after setting it to OFF cmake -j6 performs until the end. I got 1 warning at the end:

Building JAVA package csnd6.jar
warning: [options] bootstrap class path not set in conjunction with -source 8
1 warning
[100%] Built target _jcsound6
janjacobhofmann@janjacobhofmann-ThinkPad-T430:~/csound/cs6make$

However I could make the full install. Still we are not there:

There is no driver at all available at CsoundQt, so there is not output of sound. Looking at the plugins-folder it shows that there are just 26 objects in it. But I kept a copy of the folder of the previous install at my desktop. I was expecting it would be generated freshly too while compiling. Maybe I was wrong...

Sorry for the complications...

Cheers,

Jan Jacob

sound | movement | object | space
sonic architecture | site:http://www.sonicarchitecture.de
spatial electronic composition | higher order ambisonic music

what do you mean by "There is no driver at all available at CsoundQt"?
do you mean that when you go to CsoundQt's configuration > run, there is no "RT Audio Module" available?

if this is the case, you must again go into your CMakeCache.txt, and turn ON the audio modules. i have:
USE_ALSA:BOOL=ON
USE_JACK:BOOL=ON
USE_PULSEAUDIO:BOOL=ON

or did you miss sudo ldconfig?

best -
  j

Dear Joachim,
yes, there is just null as a driver available. I did not miss sudo ldconfig, but still it did not work well yet. I have got to go now, I’ll try your suggestion tomorrow…

Thanks a lot,
Jan Jacob

Thanks! I'll explore...

  -- Pete --

Csound mailing list
Csound@listserv.heanet.ie
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here