[Csnd] runtime failure MacOS

Dear list,

for me that issue is still not solved - probably because I do not exactly know how to do it. Maybe someone can give me a more detailed explanation on what to do.

First I would like to make sure, if the issue Dave reported is related/ the same as this one:

I am on Mac OSX 12.6 and my version of Csound is Csound 6.17.

The output on console is this when I try to render can be found below.
Also blue crashes when I try to render, no matter if realtime or deferred time.
Csound 6.16 runs fine, 6.17 causes these problems.

What exactly do I have to do?

Cheers,

Jan Jacob

ans-Mac-Pro:~ janjacobhofmann$ csound /Users/janjacobhofmann/Desktop/HelloWorld.csd
WARNING: could not open library '/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/libosc.dylib' (-1)
WARNING: could not open library '/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/librtjack.dylib' (-1)
UnifiedCSD: /Users/janjacobhofmann/Desktop/HelloWorld.csd
rtaudio: PortAudio module enabled ...
using callback interface
rtmidi: PortMIDI module enabled
Elapsed time at end of orchestra compile: real: 0.002s, CPU: 0.002s
sorting score ...
  ... done
Elapsed time at end of score sort: real: 0.002s, CPU: 0.002s
--Csound version 6.17 (double samples) Feb 2 2022
[commit: deff4f9aaeaf44f7db445c215f004bca8d50901f]
libsndfile-1.0.31
graphics suppressed, ascii substituted
sr = 44100.0, kr = 1378.125, ksmps = 32
0dBFS level = 32768.0, A4 tuning = 440.0
orch now loaded
audio buffered in 1024 sample-frame blocks
dyld: lazy symbol binding failed: Symbol not found: ____chkstk_darwin
  Referenced from: /Library/Frameworks/CsoundLib64.framework/Versions/6.0/../../libs/libsndfile.1.dylib
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: ____chkstk_darwin
  Referenced from: /Library/Frameworks/CsoundLib64.framework/Versions/6.0/../../libs/libsndfile.1.dylib
  Expected in: /usr/lib/libSystem.B.dylib

csound command: Abort trap
inactive allocs returned to freespace
end of score. overall amps: 0.0
     overall samples out of range: 0
0 errors in performance
Elapsed time at end of performance: real: 0.258s, CPU: 0.003s

sound | movement | object | space
sonic architecture | site: http://www.sonicarchitecture.de
spatial electronic composition | higher order ambisonic music

Csound mailing list
Csound@listserv.heanet.ie
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        Issues · csound/csound · GitHub
Discussions of bugs and features can be posted here

As a test, you might be able to grab the libsndfile.1.dylib from 6.16,
uninstall, then install 6.17 and copy that libsndfile.1.dylib in. I
think that would work.

(BTW: It should be clarified this is 10.12.6)

Potentially you could simply copy the whole libs directory from 6.16 and replace the one in 6.17 with it.

The location is

/Library/Frameworks/CsoundLib64.framework/libs

Unfortunately I don't have the means to produce binaries that support older MacOS versions at this moment.

Prof. Victor Lazzarini
Maynooth University
Ireland