[Csnd] pvanal

Hello, I just installed Csound 6.16.2 on my new Mac and was working on some FFT processing. Launching the usual command by Terminal to analyse a sound file a get this message:

cd /Volumes/
PATH=$PATH:/usr/local/bin
pvanal -n8192 -w16 -c1 Chit_el_trimin_01.aif Chit_el_trimin_01.pv
0dBFS level = 32768.0
--Csound version 6.16 (double samples) Aug 23 2021
[commit: c7601d11f029f24590917d4a1797e247eafdef21]
libsndfile-1.0.28
Error: utility 'pvanal' not found
end of score. overall amps: 0.0
     overall samples out of range: 0
0 errors in performance
Elapsed time at end of performance: real: 0.001s, CPU: 0.001s

Something went wrong in the installation of the software?

Csound mailing list
Csound@listserv.heanet.ie
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        Issues · csound/csound · GitHub
Discussions of bugs and features can be posted here

Hi Giuseppe,
have you tried invoking the pvanal utility by:
csound -U pvanal -n8192 -w16 -c1 Chit_el_trimin_01.aif Chit_el_trimin_01.pv
It should work, even if there are problems in the standalone utility. It is slightly more awkward to type. That may be solved by writing a shell script, if all else fails for the moment.

HTH.

Best wishes,

Jeanette

Jan 9 2022, Giuseppe has written:

There was a problem with loading the utilities plugin and so pvanal could not be loaded. I uploaded a fixed package about a month ago, try downloading it again.

Prof. Victor Lazzarini
Maynooth University
Ireland

Thank you Prof. Lazzarini,

I downloaded the csound-MacOS_x86_64-6.16.2.dmg file at https://csound.com/download.html. Where can I found the package you have fixed?

Giuseppe

Hi Giuseppe,

that location has the fixed package, I just checked. Try downloading again.
To make sure it’s the right one, the libstdutil.dylib file needs to have the 17 Dec date

ls -l /Library/Frameworks/CsoundLib64.framework/Resources/Opcodes64/libstdutil.dylib
-rwxr-xr-x 1 root wheel 203104 17 Dec 09:46 /Library/Frameworks/CsoundLib64.framework/Resources/Opcodes64/libstdutil.dylib

best

Victor

Thanks a lot Prof. Lazzarini! I have downloaded it again and now it works fine.

Best regards,

Giuseppe