[Csnd] plugins release

Dear All,

the first release of Csound 6 standard plugins is out now, with binaries for MacOS and Windows.

Thanks to Rory Walsh for adjusting the Windows build and producing a binary installer.

Prof. Victor Lazzarini
Maynooth University
Ireland
Csound mailing list
Csound@listserv.heanet.ie
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        Issues · csound/csound · GitHub
Discussions of bugs and features can be posted here

Wonderful news!

Thanks to Victor, Rory, Francois, Eduardo, John, and Michael.

I am happy to say that on Ubuntu 20.04, after building the Faust master branch with the Faust shared library, and setting the ABLETON_LINK_HOME environment variable, I easily built the following targets:

…/build/py/libpy.so
…/build/chua/libchua.so
…/build/image/libimage.so
…/build/AbletonLinkOpcodes/libableton_link_opcodes.so
…/build/widgets/libwidgets.so
…/build/faustcsound/libfaustcsound.so

I would very much appreciate it if some developer with a Windows development system would debug the vst3 opcodes in https://github.com/gogins/csound-vst3-opcodes. The Windows build builds on GitHub continuous integration and can be downloaded, but it crashes, while the Linux and MacOS binaries work.

Regards,
Mike

However, there’s a problem:

WARNING: could not open library ‘/home/mkg/.local/lib/csound/6.0/plugins64/libfaustcsound.so’ (/home/mkg/.local/lib/csound/6.0/plugins64/libfaustcsound.so: undefined symbol: _Z16deleteDSPFactoryP16llvm_dsp_factory)

I checked this on MacOS and libfaust 2.33.1 has it

% nm ~/lib/faust-2.33.1/lib/libfaust.2.33.1.dylib | grep _Z16deleteDSPFactoryP16llvm_dsp_factory
0000000000488fc0 T __Z16deleteDSPFactoryP16llvm_dsp_factory

So I presume you need to check your faust installation. I’ve also asked at the faust list.

Looks like the faust library you have is not compatible. I tested here on MacOS with the latest release (2.33) and I saw no issues.

Prof. Victor Lazzarini
Maynooth University
Ireland

Stéphane has confirmed in the faust list that this function is part of the current API.

I have this version:

mkg@xenakis:~/plugins/build$ faust --version
FAUST Version 2.33.1
Embedded backends:
Copyright © 2002-2021, GRAME - Centre National de Creation Musicale. All rights reserved.

With the master-dev branch of Faust I get this compiler error:

In file included from /home/mkg/faust/compiler/generator/llvm/llvm_dsp_aux.cpp:44:
/home/mkg/faust/compiler/generator/llvm/llvm_dsp_aux.cpp: In member function ‘virtual bool llvm_dsp_factory_aux::writeDSPFactoryToMachineFile(const string&, const string&)’:
/home/mkg/faust/compiler/generator/llvm/llvm_dsp_aux.hh:55:36: error: ‘F_None’ is not a member of ‘llvm::sys::fs’; did you mean ‘OF_None’?
55 | #define sysfs_binary_flag sys::fs::F_None

^~~~~~

I have this version:

mkg@xenakis:~/plugins/build$ faust --version
FAUST Version 2.33.1
Embedded backends:
Copyright © 2002-2021, GRAME - Centre National de Creation Musicale. All rights reserved.

It lacks the symbol “deleteDSPFactory”. But I will try the master-dev branch of Faust.

Thanks for checking, this should help.
Mike


Michael Gogins
Irreducible Productions
http://michaelgogins.tumblr.com
Michael dot Gogins at gmail dot com

Looks like the faust library you have is not compatible. I tested here on MacOS with the latest release (2.33) and I saw no issues.

Prof. Victor Lazzarini
Maynooth University
Ireland

Warning

This email originated from outside of Maynooth University’s Mail System. Do not reply, click links or open attachments unless you recognise the sender and know the content is safe.

However, there’s a problem:

WARNING: could not open library ‘/home/mkg/.local/lib/csound/6.0/plugins64/libfaustcsound.so’ (/home/mkg/.local/lib/csound/6.0/plugins64/libfaustcsound.so: undefined symbol: _Z16deleteDSPFactoryP16llvm_dsp_factory)


Michael Gogins
Irreducible Productions
http://michaelgogins.tumblr.com
Michael dot Gogins at gmail dot com

I am happy to say that on Ubuntu 20.04, after building the Faust master branch with the Faust shared library, and setting the ABLETON_LINK_HOME environment variable, I easily built the following targets:

…/build/py/libpy.so
…/build/chua/libchua.so
…/build/image/libimage.so
…/build/AbletonLinkOpcodes/libableton_link_opcodes.so
…/build/widgets/libwidgets.so
…/build/faustcsound/libfaustcsound.so

I would very much appreciate it if some developer with a Windows development system would debug the vst3 opcodes in https://github.com/gogins/csound-vst3-opcodes. The Windows build builds on GitHub continuous integration and can be downloaded, but it crashes, while the Linux and MacOS binaries work.

Regards,
Mike


Michael Gogins
Irreducible Productions
http://michaelgogins.tumblr.com
Michael dot Gogins at gmail dot com

Wonderful news!

Thanks to Victor, Rory, Francois, Eduardo, John, and Michael.

- dB

Dr. Richard Boulanger

Professor

Electronic Production and Design

Berklee College of Music

Professional Writing & Technology Division

Dear All,

the first release of Csound 6 standard plugins is out now, with binaries for MacOS and Windows.

https://us-west-2.protection.sophos.com?d=github.com&u=aHR0cHM6Ly9naXRodWIuY29tL2Nzb3VuZC9wbHVnaW5zL3JlbGVhc2VzL3RhZy8xLjA=&i=NWYxNzBkMDNiNTVmZGEwZmIyNjczYmRm&t=aFo2aXg5Z0FJSzBUQ0xmaEZNQWkwdVYyY2ZmYWtiUTBCMGptbmoydzJTcz0=&h=300284cd8fa541d5bdc319a3b0fadb4b

Thanks to Rory Walsh for adjusting the Windows build and producing a binary installer.

Prof. Victor Lazzarini
Maynooth University
Ireland
Csound mailing list
Csound@listserv.heanet.ie
https://us-west-2.protection.sophos.com?d=heanet.ie&u=aHR0cHM6Ly9saXN0c2Vydi5oZWFuZXQuaWUvY2dpLWJpbi93YT9BMD1DU09VTkQ=&i=NWYxNzBkMDNiNTVmZGEwZmIyNjczYmRm&t=WVZMRlI4dlFUVUZ6V2NTOUU5eE9lZnFIemtoc2hxYlBDMFFCWmtKZzhzRT0=&h=300284cd8fa541d5bdc319a3b0fadb4b
Send bugs reports to
https://us-west-2.protection.sophos.com?d=github.com&u=aHR0cHM6Ly9naXRodWIuY29tL2Nzb3VuZC9jc291bmQvaXNzdWVz&i=NWYxNzBkMDNiNTVmZGEwZmIyNjczYmRm&t=YlNrQ2lLclRLZUpGUE1iR0FyY2M1eW1NTUU5SUozWlJwMTNZU2NXT1BLOD0=&h=300284cd8fa541d5bdc319a3b0fadb4b
Discussions of bugs and features can be posted here

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list Csound@listserv.heanet.ie https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Maybe you don’t have the right version of LLVM?

According to this you need version 8 or above

https://github.com/grame-cncm/faust/wiki/Building

Prof. Victor Lazzarini
Maynooth University
Ireland

That’s strange, I have the same version and as you could see it was there.

Prof. Victor Lazzarini
Maynooth University
Ireland

On ubuntu 21.04 the faust plugins build and install ok

$ apt list --installed "*faust*"
faust-common/hirsute,hirsute,now 2.30.5~ds0-2 all [installed,automatic]
faust/hirsute,now 2.30.5~ds0-2 amd64 [installed]
libfaust2/hirsute,now 2.30.5~ds0-2 amd64 [installed,automatic]

$ apt list --installed "*llvm*" 
libllvm11/hirsute,now 1:11.0.1-2ubuntu4 amd64 [installed,automatic]
libllvm11/hirsute,now 1:11.0.1-2ubuntu4 i386 [installed,automatic]
libllvm12/hirsute,now 1:12.0.0-1ubuntu1 amd64 [installed]
libllvm4.0/now 1:4.0.1-10build1 amd64 [installed,local]
libllvm5.0/now 1:5.0.2-2 amd64 [installed,local]
libllvm9/hirsute,now 1:9.0.1-16 amd64 [installed,automatic]
llvm-11-dev/hirsute,now 1:11.0.1-2ubuntu4 amd64 [installed,automatic]
llvm-11-linker-tools/hirsute,now 1:11.0.1-2ubuntu4 amd64 [installed,automatic]
llvm-11-runtime/hirsute,now 1:11.0.1-2ubuntu4 amd64 [installed,automatic]
llvm-11-tools/hirsute,now 1:11.0.1-2ubuntu4 amd64 [installed,automatic]
llvm-11/hirsute,now 1:11.0.1-2ubuntu4 amd64 [installed,automatic]
llvm-12-dev/hirsute,now 1:12.0.0-1ubuntu1 amd64 [installed]
llvm-12-linker-tools/hirsute,now 1:12.0.0-1ubuntu1 amd64 [installed]
llvm-12-runtime/hirsute,now 1:12.0.0-1ubuntu1 amd64 [installed]
llvm-12-tools/hirsute,now 1:12.0.0-1ubuntu1 amd64 [installed]
llvm-12/hirsute,now 1:12.0.0-1ubuntu1 amd64 [installed,]
llvm-4.0-dev/now 1:4.0.1-10build1 amd64 [installed,local]
llvm-4.0-runtime/now 1:4.0.1-10build1 amd64 [installed,local]
llvm-4.0/now 1:4.0.1-10build1 amd64 [installed,local]
llvm-9-dev/hirsute,now 1:9.0.1-16 amd64 [installed,automatic]
llvm-9-runtime/hirsute,now 1:9.0.1-16 amd64 [installed,automatic]
llvm-9-tools/hirsute,now 1:9.0.1-16 amd64 [installed,automatic]
llvm-9/hirsute,now 1:9.0.1-16 amd64 [installed,automatic]
llvm-dev/hirsute,now 1:12.0-52~exp1 amd64 [installed]
llvm-runtime/hirsute,now 1:12.0-52~exp1 amd64 [installed,automatic]
llvm/hirsute,now 1:12.0-52~exp1 amd64 [installed]

Csound mailing list Send bugs reports to Discussions of bugs and features can be posted here

Thanks for confirming.

Ah, I see you are missing the LLVM IR backend. This is what I have

% ~/lib/faust-2.33.1/bin/faust --version
FAUST Version 2.33.1
Embedded backends:
   DSP to C
   DSP to C++
   DSP to CSharp
   DSP to DLang
   DSP to FIR
   DSP to Interpreter
   DSP to Java
   DSP to LLVM IR
   DSP to old C++
   DSP to Rust
   DSP to SOUL
   DSP to WebAssembly (wast/wasm)
Build with LLVM version 12.0.0
Copyright (C) 2002-2021, GRAME - Centre National de Creation Musicale. All rights reserved.

You are correct, my version of Faust did not have any back ends.

I fixed that, but I still had the opcodes crashing during load.

I finally gave up trying to build Faust from sources, and just installed the following system packages for Faust:

mkg@xenakis:~/faust/build$ apt list --installed “faust
Listing… Done
faust-common/focal,focal,now 2.20.2~ds0-1 all [installed]
faust/focal,now 2.20.2~ds0-1 amd64 [installed]
libfaust2/focal,now 2.20.2~ds0-1 amd64 [installed]

Even though deleteDSPFactory is still undefined in the Faust opcodes library, and even though on Ubuntu 20.04 the Faust version is only 2.20.2, the opcodes nevertheless build and load without error. I haven’t done fancy tests, but the example in the Csound Reference Manual runs.

Thanks,
Mike

Thanks for this. I think any Faust 2.x works (and possibly earlier versions too).

Prof. Victor Lazzarini
Maynooth University
Ireland

I’ve been porting some of the Faust examples in https://faustide.grame.fr/ to Csound patches.

In most cases, the examples are not useful in my particular rather pitch based style of composition, but I find that some of the sounds are very attractive, such as the bells. In other cases I have got sounds that I like that I can get pitches out of.

I am putting the patches in https://github.com/gogins/csound-extended/tree/develop/silencio/patches if anyone wants to look at them. The filenames all start with “Faust”.

I have a big question: Are there other open source repositories of instruments or effects created in Faust that would make sense to use in Csound?

Regards,
Mike

Looks very interesting, thanks for sharing.

Prof. Victor Lazzarini
Maynooth University
Ireland

I have booked the Faust examples that I have ported, into the csound-extended/develop branch here: https://github.com/gogins/csound-extended/tree/develop/silencio/patches.

The module system, which explains how to use such patches, is explained here: https://github.com/gogins/csound-extended/blob/develop/silencio/patches/modular_csound.pdf.

I still need to clean up some stuff, that could take a day or two.

Regards,
Mike