[Csnd] Error pvanal not found

Dera all,

I’m getting an error while using the utility pvanal. It seams like csound can’t find the pvanal utility. I can see that both pvanal and the library libstdutil.dylib are there in /usr/local/bin/pvanal and /Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/librtjack.dylib

I tried in both mac os 11.6 and 10.12.6 with the same result. Is csound missing some environment variable to know where pvanal is? Any ideas what the problenm could be?

You can see the output of the terminal bellow.

Best,

Luís

csound -U pvanal -n 1024 -c 1 -w 4 /Users/luisantunespena/Sync/arbeit/komp/2020-EinHauchVonWut/csnd/ssdir/EinHauchVonWut_Experiments01-1.aif /Users/luisantunespena/Sync/arbeit/komp/2020-EinHauchVonWut/csnd/sadir/EinHauchVonWut_Experiments01-1.pvx
0dBFS level = 32768.0
–Csound version 6.16 (double samples) Aug 23 2021
[commit: c7601d11f029f24590917d4a1797e247eafdef21]
libsndfile-1.0.28
Error: utility ‘pvanal’ not found
WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/libfluidOpcodes.dylib’ (-1)
WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/libstdutil.dylib’ (-1)
WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/libvirtual.dylib’ (-1)
WARNING: could not open library ‘/Library/Frameworks/CsoundLib64.framework/Versions/6.0/Resources/Opcodes64/librtjack.dylib’ (-1)
end of score. overall amps: 0.0
overall samples out of range: 0
0 errors in performance
Elapsed time at end of performance: real: 0.001s, CPU: 0.001s

Csound mailing list Send bugs reports to Discussions of bugs and features can be posted here

It should be OPCODE6DIR64, but you would not get such warnings if that was not set etc. They are issued if Csound tries to load them but can’t.
So that’s generally because of missing dependencies to these libraries.

- In the case of librtjack it’s because you don’t have jack installed, that’s fine.
- libvirtual depends on FLTK and that is not found either, because we’re not shipping it on MacOS (and in fact libvirtual should not be built anymore, it’s a mistake that it is there)
- llibfluidsynth.dylib also depends on Jack being installed so that’s why it’s not loading

Ah, I see, there’s a link name error in libstdutil that’s causing that problem. It is point to the wrong libsndfile.
Here’s the command to fix this

sudo install_name_tool -change libsndfile.1.dylib @loader_path/../../../../libs/libsndfile.1.dylib /Library/Frameworks/CsoundLib64.framework/Resources/Opcodes64/libstdutil.dylib

I’ll try and replace the installer to fix this.

package updated in the 6.12.2 release.

Victor, that’s it. It worked immediately. Thank you very much!
Luís

Csound mailing list Send bugs reports to Discussions of bugs and features can be posted here